成人免费无遮挡无码视频,国产无遮挡18禁网站免费,免费无码又爽又刺激软件下载

<nav id="ygnmy"></nav>
<form id="ygnmy"></form>

  • 首頁 > 開發 > 其他 > 正文

    易語言如何實現定時關機和倒計時關機(附源碼)

    2019-10-20 16:30:58
    字體:
    來源:轉載
    供稿:網友

    本文將為大家講解如何使用易語言實現定時關機和倒計時關機,并提供相關源碼,包括易語言定時關機源碼及倒計時關機源碼。

    打開易語言

    1、安裝易語言,使易語言軟件可以正常運行及編譯。

    2、打開易語言。

    易語言,定時關機,倒計時關機,源碼

    關機源碼,可2選1使用

    1、使用“關閉系統”命令來進行關閉。此命令屬于“操作系統界面功能支持庫”

    命令源碼:

    關閉系統 (#關機, 真)

    易語言,定時關機,倒計時關機,源碼

    2、使用“運行”命令來調用shutdown.exe實現關機。此命令屬于“系統核心支持庫”

    命令源碼:

    運行 (“shutdown.exe -s -t 0”, 假, )

    易語言,定時關機,倒計時關機,源碼

     

    定時關機源碼

    1、在這里使用“運行”的關機方法來進行演示。

    先做界面,6個編輯框,6個標簽,一個按鈕。

    易語言,定時關機,倒計時關機,源碼

    易語言,定時關機,倒計時關機,源碼

    2、在界面編輯窗口雙擊按鈕進入按鈕的單擊事件代碼編寫代碼。

    易語言,定時關機,倒計時關機,源碼

    易語言,定時關機,倒計時關機,源碼

    3、編寫代碼。見圖,代碼后有說明。

    代碼:

    .版本 2

    .子程序 _按鈕1_被單擊

    .局部變量 當前時間, 日期時間型, , , 用來存放點擊按鈕時的時間變量

    .局部變量 設置時間, 日期時間型, , , 用來存放點在軟件上設置的時間變量

    .局部變量 剩余秒數, 整數型, , , 用來存放離關機時間的秒數

    當前時間 = 取現行時間 ()

    設置時間 = 到時間 (編輯框1.內容 + “年” + 編輯框2.內容 + “月” + 編輯框3.內容 + “日” + 編輯框4.內容 + “時” + 編輯框5.內容 + “分” + 編輯框6.內容 + “秒”)

    剩余秒數 = 取時間間隔 (設置時間, 當前時間, #秒)

    延時 (剩余秒數 × 1000)

    運行 (“shutdown.exe -s -t 0”, 假, )

    易語言,定時關機,倒計時關機,源碼

     

    倒計時關機源碼

    1、先做界面,并進入代碼編輯窗口。這兩步可見上一步驟同樣的方法。

    界面為一個編輯框,一個標簽,一個按鈕

    易語言,定時關機,倒計時關機,源碼

    2、編寫代碼:(注意一下延遲與延時的區別,用法是一樣的。)

    .版本 2

    .支持庫 spec

    .子程序 _按鈕1_被單擊

    .局部變量 剩余秒數, 整數型, , , 用來存放離關機時間的秒數

    剩余秒數 = 到整數 (編輯框1.內容)

    延遲 (剩余秒數 × 1000)

    運行 (“shutdown.exe -s -t 0”, 假, )

    易語言,定時關機,倒計時關機,源碼

     

    注意事項

    易語言在未購買正式版的時候可以編譯,但是不能生成EXE

    延時() 與 延遲() 命令的用法。


    注:相關教程知識閱讀請移步到易語言教程頻道。
    發表評論 共有條評論
    用戶名: 密碼:
    驗證碼: 匿名發表
    成人免费无遮挡无码视频,国产无遮挡18禁网站免费,免费无码又爽又刺激软件下载